MasterCard Processing
Incident Report for Gateway Services
Resolved
The issue previously reported with Mastercard branded cards appears to be now resolved, we will continue to monitor the situation closely.
Posted 9 days ago. Jul 12, 2018 - 14:08 CDT
Investigating
All merchants may be experiencing intermittent declines on MasterCard branded cards. Our support teams are working with MasterCard for information on a resolution.
Posted 9 days ago. Jul 12, 2018 - 13:40 CDT
This incident affected: Credit Card Processing.