Elavon Processing Issues
Incident Report for Gateway Services
Resolved
Elavon processing network issues resolved.
Posted 8 months ago. Nov 14, 2017 - 09:13 CST
Identified
Elavon confirmed issues with a network provider.
Posted 8 months ago. Nov 14, 2017 - 08:46 CST
Investigating
We are currently investigating processing issues on the Elavon platform.
Posted 8 months ago. Nov 14, 2017 - 08:34 CST