Phone system issues
Incident Report for Gateway Services
Resolved
The issue with the phone system has been resolved.
Posted about 2 months ago. Aug 24, 2017 - 08:57 CDT
Identified
We have received confirmation from our phone system provider of issues with their platform and are unable to answer calls that are coming in. As always, support will still be available via e-mail.
Posted about 2 months ago. Aug 24, 2017 - 08:30 CDT