Application for Electronic Check Activation failures
Incident Report for Gateway Services
Resolved
We have not observed any recent errors submitting electronic check applications. Errors occurred for a subset of merchants from 9:08 AM CDT to 11:41 AM CDT.
Posted Jul 03, 2024 - 12:50 CDT
Investigating
Engineers are investigating errors occurring when when merchants submit applications to activate electronic check processing.
Posted Jul 03, 2024 - 12:01 CDT
This incident affected: Control Panel.