TSYS processing

Incident Report for Gateway Services

Resolved

There have been no further timeouts on the TSYS platform. Transactions timed out between 13:14:40 - 13:17:09 CDT and again from 13:45:30 - 13:47:56 CDT.
Posted May 20, 2025 - 14:49 CDT

Investigating

We are currently monitoring transactions on the TSYS platform. Transactions timed out between 13:14:40 - 13:17:09 CDT and again from 13:45:30 - 13:47:56 CDT.
Posted May 20, 2025 - 13:54 CDT
This incident affected: Credit Card Processors (TSYS).