Tsys Processing

Incident Report for Gateway Services

Resolved

No further connection timeouts on the platform have been observed.
Posted Mar 18, 2026 - 16:22 CDT

Monitoring

Our system experienced response timeouts to the Tsys platform between 2026-03-18 16:01 and 2026-03-18 16:03. Engineers continue monitoring for additional issues.
Posted Mar 18, 2026 - 16:01 CDT
This incident affected: Transaction API, Credit Card Processing and Credit Card Processors (TSYS).