Vantiv Now Worldpay eCommerce - Terminal Capture (Litle & Co.) Processing Issues

Incident Report for Gateway Services

Resolved

There have been no further errors on the Vantiv Now Worldpay eCommerce platform. Errors occurred between 10:23:09 AM - 10:28:26 AM CST.
Posted Mar 05, 2025 - 10:46 CST

Investigating

Engineers are investigating processing issues to the Vantiv Now Worldpay eCommerce platform as of 10:23 AM CST.
Posted Mar 05, 2025 - 10:23 CST
This incident affected: Credit Card Processing.