Issue affecting transactions processing via Chase Salem/Stratus

Incident Report for Gateway Services

Resolved

This incident is now resolved
Posted Jun 05, 2025 - 08:46 CDT

Monitoring

We have identified an issue affecting transactions processing via Chase Salem/Stratus. We are working on a resolution to be implemented as soon as possible. An update will be provided shortly.
Posted Jun 05, 2025 - 06:59 CDT
This incident affected: Credit Card Processors (Chase Paymentech).