Paymentech Tampa processing
Incident Report for Gateway Services
Resolved
There have been no further errors on the Paymentech Tampa platform. Errors occurred between 7:41:09 AM - 7:59:33 AM CDT.
Posted Jun 26, 2023 - 08:17 CDT
Investigating
Engineers are investigating connection issues to the Paymentech Tampa platform as of 7:41 PM CDT.
Posted Jun 26, 2023 - 08:01 CDT
This incident affected: Credit Card Processors (Chase Paymentech).