Collect Checkout - Increased Error Rates and Latency

Incident Report for Gateway Services

Resolved

Engineers are no longer observing elevated error rates or load times on Collect Checkout. This incident is now resolved.
Posted Jun 20, 2025 - 13:22 CDT

Monitoring

Mitigations deployed have alleviated the elevated latency. The team continues to monitor for any return of slowness
Posted Jun 19, 2025 - 22:20 CDT

Update

Engineering continues to work with upstream providers to mitigate the issue. Error rates have significantly improved, but high latency for Collect Checkout calls is still being observed.
Posted Jun 19, 2025 - 14:30 CDT

Identified

Engineering is reviewing issues resulting increased error rates and load times with Collect Checkout
Posted Jun 19, 2025 - 12:58 CDT
This incident affected: Control Panel.