Quickclick.com - Service Incident

Incident Report for Gateway Services

Resolved

Engineers have resolved and confirmed the impacted services are operational and stable.
Posted Mar 20, 2026 - 06:48 CDT

Investigating

We are currently investigating a possible service incident with www.quickclick.com. Some customers may be experiencing service issues as a result. Our engineers are working to investigate and resolve the issue.
Posted Mar 20, 2026 - 04:21 CDT
This incident affected: Credit Card Processing.