Delayed settlements

Incident Report for Gateway Services

Resolved

Delayed batches have been submitted to processors for settlement. Some batches may take additional time for their current status to be reflected in reports.
Posted Jun 22, 2026 - 07:20 CDT

Monitoring

Engineers are investigating settlements delayed from approximately 10:40 PM CDT. The delayed batches are submitting as of 6:35 AM CDT.
Posted Jun 22, 2026 - 06:38 CDT