The internal system issue that caused a delay in the posting of certain First Data Rapid Connect transactions for settlement has now been resolved. The affected transactions are those normally submitted to Fiserv between 00:35 and 01:35 UTC; these were submitted by 02:35 UTC. Additionally, transactions typically submitted between 07:15 and 08:15 UTC were submitted by 12:06 UTC. As a result, the associated funding to accounts may have been delayed.
Posted Jun 17, 2025 - 08:09 CDT
Identified
The internal system issue that caused a delay in the posting of certain First Data Rapid Connect transactions for settlement has now been identified and is being resolved. Transactions that are normally submitted to Fiserv between 00:35 and 01:35 UTC were submitted by 02:35 UTC. Other transactions are still being processed. A further update will be provided shortly with more information.
Posted Jun 17, 2025 - 05:34 CDT
Investigating
An internal system issue has caused a delay in the posting of certain First Data Rapid Connect transactions to Fiserv for settlement. As a result, the corresponding funding to accounts may also have been delayed. A further update will be provided shortly with more information.
Posted Jun 17, 2025 - 04:03 CDT
This incident affected: Credit Card Processors (First Data Nashville North).